Gears 0.5.33 Workaround

I created a workaround for my gears problem by manually changing the version number within the .xpi file from 0.5.32 to 0.5.33. It seems to be working. Since yesterday there was no attempt for an automatic update.

You can download the patched file here: gears-linux-opt-0.5.32-patched.xpi

[Update 02/04/2010]
There is a more recent version than 0.5.33 available. The patched file contains now the version number 0.5.36

Gears 0.5.33

Gears tried to update itself automatically, but stopped with an error telling, it is not compatible with my system, all the time. My workaround: uninstall, and install it manually failed. I was not able to install it again.

The file install.rdf within the actual .xpi file shows:

<!-- Prevent this XPI from being installed on the wrong platform. -->
<em:targetPlatform>Linux_x86_64-gcc3</em:targetPlatform>

The problem is, google packed the 64-bit version instead the 32-bit version, which will not run on a 32-bit System.

To get gears running again I had to install an older, correct packaged version. Gears version 0.5.32 can be downloaded here:
https://dl-ssl.google.com/gears/0.5.32.0/gears-linux-opt.xpi